vHosting 0
vhs728x90
Risultati da 1 a 10 di 10
  1. #1
    Data Registrazione
    30/05/14
    Messaggi
    48
    Grazie dati
    3
    Ringraziato 5 volte in 3 post
    Mentioned
    0 Post(s)

    Predefinito forum non invia piu mail agli utenti

    salve, da qualche giorno il mio forum mybb su altervista non invia piu le mails di notifica agli utenti.

    uso la versione 1.6.12 di mybb

    ho creato una pagina di test per simulare
    l'invio di mybb e funziona correttamente.

    cosa posso controllare?

    grazie.

    Codice:
    <?php
    
        if ( $_SERVER['REQUEST_METHOD'] === 'POST' )  {
    
            $to = $_POST['email'];
    
            if( mail( $to, 'Testing mail', 'This is a mailing test to see if PHP mail works.' ) ) {
            
                echo 'Mail was sent by PHP to ' . $to;
            
            } else {
            
                echo 'PHP could not send the mail to ' . $to;
                
                print_r( error_get_last() );
    
          }
    
        } else {
    
    ?>
    
        <form  method="post">
            E-mail: <input type="text" name="email"><br>
            <input type="submit" value="Invia Mail">
        </form>
    
    <?php
        
        }
    
    ?>
    Ultima modifica di MaxSteel; 26-10-16 alle 15:33 Motivo: Aggiunto tag CODE

  2. #2
    Data Registrazione
    15/09/08
    Località
    Taranto, Italy
    Età
    35
    Messaggi
    38,141
    Grazie dati
    1,580
    Ringraziato 2,932 volte in 2,572 post
    Mentioned
    152 Post(s)

    Predefinito Re: forum non invia piu mail agli utenti

    Come fai l'invio? Tramite PHP o connessione SMTP?

  3. #3
    Data Registrazione
    30/05/14
    Messaggi
    48
    Grazie dati
    3
    Ringraziato 5 volte in 3 post
    Mentioned
    0 Post(s)

    Predefinito Re: forum non invia piu mail agli utenti

    dove si vede? credo usi il sistema di default di mybb.

  4. #4
    Data Registrazione
    15/09/08
    Località
    Taranto, Italy
    Età
    35
    Messaggi
    38,141
    Grazie dati
    1,580
    Ringraziato 2,932 volte in 2,572 post
    Mentioned
    152 Post(s)

    Predefinito Re: forum non invia piu mail agli utenti

    Ok quindi tramite PHP.

    Mi dai l'IP del server che usi?

  5. #5
    Data Registrazione
    30/05/14
    Messaggi
    48
    Grazie dati
    3
    Ringraziato 5 volte in 3 post
    Mentioned
    0 Post(s)

    Predefinito Re: forum non invia piu mail agli utenti

    non lo so l'ip, comunque il problema è circoscritto al dominio live.it, gmail ed altre che ho provato funzionano.

  6. #6
    Data Registrazione
    23/11/09
    Messaggi
    5,270
    Grazie dati
    498
    Ringraziato 1,038 volte in 885 post
    Mentioned
    172 Post(s)

    Predefinito Re: forum non invia piu mail agli utenti

    Se usi un server condiviso è possibile che l'IP della macchina sia finito in qualche blacklist.
    Per i domini Microsoft puoi far riferimento a questa pagina: http://mail.live.com/mail/troubleshooting.aspx.

    Eventualmente, chiedi all'amministratore del server/hosting provider di controllare per conto tuo.
    "In theory, theory and practice are the same; in practice they, are not." · Yogi Berra

  7. #7
    Data Registrazione
    04/01/17
    Messaggi
    2
    Grazie dati
    0
    Ringraziato 0 volte in 0 post
    Mentioned
    0 Post(s)

    Predefinito Re: forum non invia piu mail agli utenti

    Mi accodo alla discussione perchè ho lo stesso problema con un forum creato su altervista.
    Ho provato sia con PHP che SMTP ma niente, alcuni indirizzi mail come @hotmail.com funzionano ma altri (es: @tiscali.it) no.

  8. #8
    Data Registrazione
    04/01/17
    Messaggi
    2
    Grazie dati
    0
    Ringraziato 0 volte in 0 post
    Mentioned
    0 Post(s)

    Predefinito Re: forum non invia piu mail agli utenti

    Il problema è stato risolto e non riguarda myBB. Il mancato invio delle mail è un problema interno di Altervista e affligge non solo myBB ma qualsiasi board o cms installato.

  9. #9
    Data Registrazione
    23/11/09
    Messaggi
    5,270
    Grazie dati
    498
    Ringraziato 1,038 volte in 885 post
    Mentioned
    172 Post(s)

    Predefinito Re: forum non invia piu mail agli utenti

    Grazie per l'informazione, Tiger69.
    "In theory, theory and practice are the same; in practice they, are not." · Yogi Berra

  10. #10
    Data Registrazione
    26/02/17
    Messaggi
    5
    Grazie dati
    0
    Ringraziato una volta in un post
    Mentioned
    0 Post(s)

    Predefinito Re: forum non invia piu mail agli utenti

    Avevo anch'io lo stesso problema inconsapevolmente avete aiutato anche a me grazie

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
Seguici!
P.IVA: 02750560738
Cionfs © - Cionfs ® - Marchio registrato numero 0001524896
© Cionfs'Forum CMS - Cionfs'Forum CMS - Guide Gratis - Supporto CMS - E' vietata la copia anche parziale senza autorizzazione.
Questo sito utilizza cookies di analytics su dati esclusivamente aggregati e cookies di terze parti per migliorare l'esperienza dell'utente tramite plugin sociali e video.
Cliccando su oppure continuando la navigazione sul sito accetti i cookies. Per l'informativa completa clicca qui.