vHosting 0
vhs728x90
Risultati da 1 a 9 di 9
  1. #1
    Data Registrazione
    08/09/11
    Località
    Catania!
    Età
    36
    Messaggi
    269
    Grazie dati
    17
    Ringraziato 8 volte in 8 post
    Mentioned
    0 Post(s)

    Question Lingua in Avanzate Template lato amministrazione.

    Salve ragazzi.
    Ho creato un template personalizzato.
    L unico inconveniente è che quando devo settare i parametri avanzati dal pannello amministratore la lingua non viene convertita con tutto che l ho settata e tradotta (anche se senza motivo visto che di default c'era).
    Come mai!?

    file templateDetails.xml
    Codice:
    	<files>....
    		<folder>language</folder>....
    	</files>
    	<positions>
                      ....
    	</positions>
    	
    	<languages folder="language">
    		<language tag="it-IT">it-IT/it-IT.tpl_xxxx.ini</language>
    	</languages>
    	
    	<config>
    		<fields name="params">
    			<fieldset name="advanced">
    				 <field name="wrapperSmall" type="text" default="53"
    					label="TPL_XXXX_FIELD_WRAPPERSMALL_LABEL"
    					description="TPL_XXXX_FIELD_WRAPPERSMALL_DESC"
    					filter="integer" /> 
                            ......
    file it-IT/it-IT.tpl_xxxx.ini
    Codice:
    ; Joomla! Project
    ; Copyright (C) 2005 - 2012 Open Source Matters. All rights reserved.
    ; License GNU General Public License version 2 or later; see LICENSE.txt, see LICENSE.php
    ; Note : All ini files need to be saved as UTF-8 - No BOM
    
    TPL_XXXX_ADDITIONAL_INFORMATION="Informazioni Addizionali"
    TPL_XXXX_ALTCLOSE="e' chiuso"
    TPL_XXXX_ALTOPEN="e' aperto"
    .....
    tutto rigorosamente così strutturato:


    e infine il file index.php
    Codice:
    <?php
    ...
    defined('_JEXEC') or die;
    ....
    // get params
    $color			= $this->params->get('templatecolor');
    $logo			= $this->params->get('logo');
    $navposition	= $this->params->get('navposition');
    $app			= JFactory::getApplication();
    $doc			= JFactory::getDocument();
    $templateparams	= $app->getTemplate(true)->params;
    
    ?>
    <?php if(!$templateparams->get('html5', 0)): ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <?php else: ?>
    	<?php echo '<!DOCTYPE html>'; ?>
    <?php endif; ?>
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="<?php echo $this->language; ?>" lang="<?php echo $this->language; ?>" dir="<?php echo $this->direction; ?>" >
    	<head>

  2. #2
    Data Registrazione
    15/09/08
    Località
    Taranto, Italy
    Età
    35
    Messaggi
    38,131
    Grazie dati
    1,579
    Ringraziato 2,932 volte in 2,572 post
    Mentioned
    152 Post(s)

  3. Il seguente utente ha ringraziato cionfs per questo post

    Alfr3d (11-02-12)

  4. #3
    Data Registrazione
    08/09/11
    Località
    Catania!
    Età
    36
    Messaggi
    269
    Grazie dati
    17
    Ringraziato 8 volte in 8 post
    Mentioned
    0 Post(s)

    Predefinito Riferimento: Lingua in Avanzate Template lato amministrazione.

    Ricordavo di averlo visto.
    Do un ulteriore occhiata.

  5. #4
    Data Registrazione
    08/09/11
    Località
    Catania!
    Età
    36
    Messaggi
    269
    Grazie dati
    17
    Ringraziato 8 volte in 8 post
    Mentioned
    0 Post(s)

    Predefinito Riferimento: Lingua in Avanzate Template lato amministrazione.

    Allora, attivando il debugger per la lingua, e andando nelle impostazioni del template avanzate, in basso leggo:

    **File lingua caricati**
    **Caricato** : JROOT/administrator/language/it-IT/it-IT.ini
    **Caricato** : JROOT/administrator/language/it-IT/it-IT.plg_system_logout.ini
    **Caricato** : JROOT/administrator/language/it-IT/it-IT.lib_joomla.ini
    **Caricato** : JROOT/administrator/language/it-IT/it-IT.tpl_bluestork.ini
    **Caricato** : JROOT/administrator/language/it-IT/it-IT.com_templates.ini
    **Non caricato** : JROOT/language/it-IT/it-IT.tpl_XXXX_theme.ini
    **Non caricato** : JROOT/templates/sabao_theme/language/it-IT/it-IT.tpl_XXXX_theme.ini
    **Non caricato** : JROOT/language/en-GB/en-GB.tpl_XXXX_theme.ini
    **Non caricato** : JROOT/templates/sabao_theme/language/en-GB/en-GB.tpl_XXXX_theme.ini


    Come mai non me li carica?

    il file TemplateDetails.xml l ho aggiornato così:

    Codice:
    <languages>
    	        <language tag="en-GB">en-GB.tpl_beez.ini</language>
    	        <language tag="it-IT">it-IT/it-IT.tpl_XXXX.ini</language>
    	    </languages>
    
    	    <administration>
    	        <languages folder="admin">
    	            <language tag="en-GB">en-GB.tpl_beez.ini</language>
    	            <language tag="it-IT">it-IT/it-IT.tpl_XXXX.ini</language>
    	        </languages>
    	    </administration>

  6. #5
    Data Registrazione
    15/09/08
    Località
    Taranto, Italy
    Età
    35
    Messaggi
    38,131
    Grazie dati
    1,579
    Ringraziato 2,932 volte in 2,572 post
    Mentioned
    152 Post(s)

    Predefinito Riferimento: Lingua in Avanzate Template lato amministrazione.

    Al posto di XXXX ci metti il nome giusto?

  7. #6
    Data Registrazione
    08/09/11
    Località
    Catania!
    Età
    36
    Messaggi
    269
    Grazie dati
    17
    Ringraziato 8 volte in 8 post
    Mentioned
    0 Post(s)

    Predefinito Riferimento: Lingua in Avanzate Template lato amministrazione.

    Si Antonio.

  8. #7
    Data Registrazione
    15/09/08
    Località
    Taranto, Italy
    Età
    35
    Messaggi
    38,131
    Grazie dati
    1,579
    Ringraziato 2,932 volte in 2,572 post
    Mentioned
    152 Post(s)

    Predefinito Riferimento: Lingua in Avanzate Template lato amministrazione.

    Ovviamente i files esistono nelle cartelle, giusto?

  9. #8
    Data Registrazione
    08/09/11
    Località
    Catania!
    Età
    36
    Messaggi
    269
    Grazie dati
    17
    Ringraziato 8 volte in 8 post
    Mentioned
    0 Post(s)

    Predefinito Riferimento: Lingua in Avanzate Template lato amministrazione.

    Ovvio.

  10. #9
    Data Registrazione
    15/09/08
    Località
    Taranto, Italy
    Età
    35
    Messaggi
    38,131
    Grazie dati
    1,579
    Ringraziato 2,932 volte in 2,572 post
    Mentioned
    152 Post(s)

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
Seguici!
P.IVA: 02750560738
Cionfs © - Cionfs ® - Marchio registrato numero 0001524896
© Cionfs'Forum CMS - Cionfs'Forum CMS - Guide Gratis - Supporto CMS - E' vietata la copia anche parziale senza autorizzazione.
Questo sito utilizza cookies di analytics su dati esclusivamente aggregati e cookies di terze parti per migliorare l'esperienza dell'utente tramite plugin sociali e video.
Cliccando su oppure continuando la navigazione sul sito accetti i cookies. Per l'informativa completa clicca qui.