vHosting 0
vhs728x90
Risultati da 1 a 5 di 5
  1. #1
    Data Registrazione
    23/07/19
    Messaggi
    14
    Grazie dati
    0
    Ringraziato una volta in un post
    Mentioned
    0 Post(s)

    Predefinito Non mi è possibile aggiornare da 1.6 a 1.8

    Ciao a tutti!

    Ho già scritto sul forum ufficiale ma non mi ha risposto nessuno.
    Ho cercato di fare upgrade da 1.6 a 1.8 ma si ferma alla schermata:

    Citazione Originariamente Scritto da Host
    Updating Database
    Performing necessary upgrade queries...
    Click next to continue with the upgrade process.

    [Automatically redirecting...]
    Praticamente rimane fisso per ore su questa schermata e non va mai avanti.
    Considerando che ho il forum su altervista, ho pensato il problema fosse il server poco potente o non propriamente configurato per fare queste manovre un po' più pesanti nonostante il mio db è di soli 55mb.
    Tant'è che ho installato AAMPS e ho provato a farlo in locale per poi uppare il db aggiornato su altervista ma anche in locale ho riscontrato lo stesso identico problema.

    Sapete come risolvere? :(

  2. #2
    Data Registrazione
    23/11/09
    Messaggi
    5,270
    Grazie dati
    498
    Ringraziato 1,038 volte in 885 post
    Mentioned
    172 Post(s)

    Predefinito Re: Non mi è possibile aggiornare da 1.6 a 1.8

    Probabilmente PHP raggiunge il limite imposto per la memoria o il tempo di esecuzione prima che lo script di upgrade finisca di fare le sue cose... Visto che hai modo di sperimentare in locale prova ad aumentare i valori dei parametri memory_limit e max_execution_time nel tuo php.ini. In ogni caso, controlla i log di apache per un eventuale errore senza un messaggio di errore chiaro è difficile suggerirti cosa fare.
    "In theory, theory and practice are the same; in practice they, are not." · Yogi Berra

  3. #3
    Data Registrazione
    23/07/19
    Messaggi
    14
    Grazie dati
    0
    Ringraziato una volta in un post
    Mentioned
    0 Post(s)

    Predefinito Re: Non mi è possibile aggiornare da 1.6 a 1.8

    Ho modificato il php.ini come da te suggerito inserendo questi limiti:
    Codice:
    max_execution_time = 0
    memory_limit = 2048M
    Citazione Originariamente Scritto da access.log Apache
    ::1 - - [24/Jul/2019:18:35:34 +0200] "GET / HTTP/1.1" 503 2068::1 - - [24/Jul/2019:18:35:34 +0200] "GET /index.php?action=mybb_logo HTTP/1.1" 200 12651
    ::1 - - [24/Jul/2019:18:36:08 +0200] "GET /install/upgrade.php HTTP/1.1" 200 4325
    ::1 - - [24/Jul/2019:18:36:09 +0200] "GET /install/stylesheet.css HTTP/1.1" 304 -
    ::1 - - [24/Jul/2019:18:36:09 +0200] "GET /jscripts/jquery.js?ver=1821 HTTP/1.1" 304 -
    ::1 - - [24/Jul/2019:18:36:09 +0200] "GET /jscripts/general.js?ver=1821 HTTP/1.1" 304 -
    ::1 - - [24/Jul/2019:18:36:09 +0200] "GET /install/images/logo.png HTTP/1.1" 304 -
    ::1 - - [24/Jul/2019:18:36:09 +0200] "GET /install/images/active.png HTTP/1.1" 304 -
    ::1 - - [24/Jul/2019:18:36:09 +0200] "GET /install/images/submit_bg.png HTTP/1.1" 304 -
    ::1 - - [24/Jul/2019:18:36:11 +0200] "POST /install/upgrade.php HTTP/1.1" 200 1605
    Considerando che il db è meno di 53 mb, e che stia facendo l'operazione in localhost.... 10 minuti mi sembrano già tanti e sta ancora fermo su quella pagina di "Updating Database".
    Sono andato nella pagina Monitor del phpmyadmin e questo è quello che mi mostra:


    ..Stesso screen dopo 1 minuto.


    Non ci sono errori nel log di errori di Apache.

  4. #4
    Data Registrazione
    23/07/19
    Messaggi
    14
    Grazie dati
    0
    Ringraziato una volta in un post
    Mentioned
    0 Post(s)

    Predefinito Re: Non mi è possibile aggiornare da 1.6 a 1.8

    Risolto aggiornando da 1.6.18 a 1.8.12, poi da 1.8.12 a 1.8.21
    Sono confuso, non mi è venuto in mente di farlo prima...

  5. #5
    Data Registrazione
    15/09/08
    Località
    Taranto, Italy
    Età
    36
    Messaggi
    38,144
    Grazie dati
    1,580
    Ringraziato 2,933 volte in 2,573 post
    Mentioned
    152 Post(s)

    Predefinito Re: Non mi è possibile aggiornare da 1.6 a 1.8

    Si vede che il passaggio è bloccato per qualche motivo.

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
Seguici!
P.IVA: 02750560738
Cionfs © - Cionfs ® - Marchio registrato numero 0001524896
© Cionfs'Forum CMS - Cionfs'Forum CMS - Guide Gratis - Supporto CMS - E' vietata la copia anche parziale senza autorizzazione.
Questo sito utilizza cookies di analytics su dati esclusivamente aggregati e cookies di terze parti per migliorare l'esperienza dell'utente tramite plugin sociali e video.
Cliccando su oppure continuando la navigazione sul sito accetti i cookies. Per l'informativa completa clicca qui.